SFTP Session Limit


Author
Message
dw
dw
Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)
Group: Forum Members
Posts: 2, Visits: 8
Hi,

We are only using the SFTP fuction included in the PragmaFortress suite.  We had suddenly started receiving the following errors in our event log:

source: FortressSSH
Event id: 3
Remote Address xxx.xxx.xxx.xxx:
 ssion limit reached. New SSH sessions rejected.

This is causing processes to fail when running overnight.  Just wondering why we would receive this message?  It is happening at all times, including overnight when activity is minimal.

Thanks,

D
Technical Support Group...
Technical Support Group (TSG)
Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)
Group: Moderators
Posts: 94, Visits: 447
Hello,

Most likely you have orphan sessions on the server that are taking up session counts.

There are two ways to clean up orphan sessions.

The first is the Server to Client Heartbeat under any configured user or Default user Handheld page. This will send a signal to the client after theconfigured period of time, then disconnect the session, if the server does notreceive a response from the client.

The other is the Idle Session Timeout under the UserGeneral Settings page. This will shut the session down after a fixed period of inactivity.

I hope this helps.

Regards,

Beth Redd
Technical Support Group (TSG)
Pragma Systems, Inc.


Pragma Systems Technical Support
13809 Research Blvd, #675
Austin, TX 78750
http://www.pragmasys.com
dw
dw
Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)
Group: Forum Members
Posts: 2, Visits: 8
Hi,

Thanks for the reply.  Unfortunately the setting you have mentioned only seem to be available in the Users section.  We are only using SFTP and have only setup SFTP users, and so do not have those options available.  We have experienced the issue again this morning and when I check the session manager there was only one connection to the server - not sure why it thinks it has reached a session limit?
bethredd
bethredd
Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)
Group: Administrators
Posts: 81, Visits: 180
The settings for the Default user will apply to all sessions, including the SFTP sessions.

Please check your Task Manager, or use our ps utility, included with the server, to list the number of sshd.exe, or sshd64.exe, processes on the server. These processes are the ones that mark the number of sessions.

Beth Redd
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Reading This Topic

Login

Explore
Messages
Mentions
Search