Set up public key login from Linux to Windows Fortress SSH server


Set up public key login from Linux to Windows Fortress SSH server
Author
Message
haribol
haribol
Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)
Group: Forum Members
Posts: 4, Visits: 9
Dear Support, we just installed Pragma ssh server on windows 2012 server and trying to connect from Linux machine using the same user id from which i logged into windows server ( using rdp) .I can connect using ssh cmd fro linux and password. Passwd is same as i use to login to Windows using RDP. I can login to using password. I am trying to set up linux public keys to Fortress server using the steps given in the link -

http://forums.pragmasys.com/Topic151.aspx

However, when i connect from Linux RedHat server i am getting password prompted. At this point we have not created any sshusers we are just using our windows login user which i feel is deafult one.

In the link it is said that with SSH -i ( pub key path) ...but seems it is given private key path ( not sure why ??).

I could see

here are the few details which might help you to advise -

Using password i can login from ssh ( Linux to win ) - My default home dir is - C:\users\windowsuser >

Public key options - Allow auth from registry ( ticked yes), Automatically store keys in reg ( yes)
Allow auth from file (yes), Store keys in auth file ( yes) .

File loc of authorised_key2" file is shown as - %APPDATA%\PragmaSSH

Auth methods
Password ( yes), Pub key / Certificate ( yes)
GSSAPI Auth ( unchecked)
------------------------------------------------------------
I could see that after running ssh -i (abc.pub) keys are inserted in file under %APPDATA%\PragmaSSH ..but that was not same as my pub key. I deleted the entry and copied the public key there. But still i am unable to login using key it still asks me password.

Could you please help?

Thanks

Technical Support Group...
Technical Support Group (TSG)
Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)Pragmateer (119 reputation)
Group: Moderators
Posts: 94, Visits: 447
Hello,

Most likely you are getting prompted for password to cache your key in the registry, since you have the option checked to store keys in the registry. Please check the password prompt and see if it says "Authenticated with partial success".

The password is necessary if your user is going to do any kind of network access, or any administrative tasks. If you do not need a cached password, turn off any feature that would ask for it.

Those features include:

Authentication -> Password Options page:
Store Passwords. This should be set to Never.
Authentication -> Public Key Options page:
Store keys in authorized file should be unchecked
Automatically store keys in registry should be unchecked.


Pragma Systems Technical Support
13809 Research Blvd, #675
Austin, TX 78750
http://www.pragmasys.com
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Reading This Topic

Login

Explore
Messages
Mentions
Search