Pragma interfering with Windows Mobile Powersave settings?


Author
Message
supersub70
supersub70
Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)
Group: Forum Members
Posts: 2, Visits: 12
Hi, new to Pragma.

We are using Honeywell Dolphin 7600 HHT's with Wavelink TE software.

We are noticing strange behaviour and initially blamed Wavelink TE however it seems to happen when the end user interacts with Log on/Off Pragma session. Something is turning Windows Powersave back on!

Here's the troubleshooting steps;

1. We untick the Powersave on Battery setting within Windows Mobile (6)

2. Open Wavelink - check setting powersave is still off

3. Enter to connect to Pragma - check setting and somehow Powersave has been ticked back on

4. Turn power save off

5. Log in - check power save is still off

6. log out of Pragma session - check Powersave and it has been turned back on again!

This is causing us all sorts of issues in the warehouse with the HHT's.

Please help

Cheers

SS 
Tags
bethredd
bethredd
Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)
Group: Administrators
Posts: 81, Visits: 180
Normally there is nothing in our connection or disconnect that should cause a powersaver option to change.

I suggest you run a test session through our protan program and send the connection string and disconnection string to the client developer to see if there is anything in those strings that would turn the saver on.

Here is how you run protan.

1. Open a dos prompt on the server, type protan 911 localhost 23 -R
        You can use any port you want for the first value. You should see a prompt that says "listening...".

2. On the client connect to the server, but use the first value that you specified in the protan command line, i.e.
        telnet servername 911

3. Connect the client to the point where the powersaver turns on.

4. In the protan window there should be a line that data was sent to the client.

4. Type CTRL-C to exit protan.

5. On the server, in the same directory where protan was launched, there will be two files named localhost1.txt and localhost1_raw.txt. These files will contain the data sent between the client and the server. 

6. Rename those files.

7. Run the same test as you described below.

8. Again close protan and rename the files.

Feel free to send me the files if you need help interpreting them. I can let you know which strings would most likely be the ones turning the powersaver on. Then you can send those sequences to Wavelink to see if they can tell for sure which would be turning it on. We can then configure the server not to send those sequences.

Beth Redd
supersub70
supersub70
Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)
Group: Forum Members
Posts: 2, Visits: 12
Hi Thanks for the Reply.

I did have a reply from the company who recommended Pragma/Wavelink solution, and they suggested that I set the idle Session timeout in the Local Server Configuration to 50 minutes. Previously it was not configured. Since that new config has been applied the Windows Powersave setting no longer appears to be changing on login/logout.

Does that make any sense to you?

I'm still tempted to set it back and try your troubleshooting tip and capture the session info.
bethredd
bethredd
Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)Pragmateer (97 reputation)
Group: Administrators
Posts: 81, Visits: 180
Well I'm glad that fixed the problem, but I agree that it doesn't make sense with your original test. The idle session timeout feature does not affect anything until the configured idle period has occurred. It would not change anything with the initialization or termination strings.

I agree that it would be interesting to do the protan test.

Beth Redd
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Reading This Topic

Login

Explore
Messages
Mentions
Search